Commit f37eca43 authored by abuddenberg's avatar abuddenberg
Browse files

Version 1.2

parent 03a91b8a
......@@ -117,3 +117,12 @@ update will cause "Parent dissociation failed" messages to appear--these can be
Remove a parent from a figure
gcis.delete_figure_parent_assoc('nca3', 'ten-indicators-of-a-warming-world', Parent.from_obj(cmip3))
Building a source distribution
------------------------------
$ python setup.py sdist
This builds a .tar.gz file of this package.
\ No newline at end of file
......@@ -6,7 +6,7 @@ from requests.packages.urllib3.exceptions import InsecureRequestWarning
requests.packages.urllib3.disable_warnings(InsecureRequestWarning)
from gcis_clients import GcisClient, SurveyClient, survey_token, gcis_dev_auth, gcis_stage_auth
from gcis_clients.domain import Report, Chapter
from domain import Report, Chapter
from sync_utils import realize_parents, realize_contributors
from states import sync_metadata_tree
......
......@@ -19,16 +19,16 @@ class PyTest(TestCommand):
setup(
name='GcisPyClient',
version='1.1.2',
version='1.2.0',
author='Andrew Buddenberg',
author_email='andrew.buddenberg@noaa.gov',
packages=find_packages(),
scripts=['bin/example', 'bin/sync_surveys.py'],
scripts=['bin/example', 'bin/sync_surveys.py', 'bin/sync_states.py'],
url='http://data.globalchange.gov',
description='Client for GCIS webservices',
long_description=open('README.md').read(),
license='New BSD',
data_files = [("", ["LICENSE.txt", "README.md"])],
data_files=[("", ["LICENSE.txt", "README.md"])],
install_requires=[
"requests >= 2.1.0",
"python-dateutil >= 2.2",
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment